Grav Scheduler "Cron Not Available" - 1.6 Beta 6

#1

I’m trying to enable the scheduler function. I’ve followed the instructions per the admin panel, and have the grav/scheduler listed in my crontab. However, “Cron Not Available” is still listed at the top of the scheduler page, and it doesn’t appear to have run any of the jobs. When I run scheduler -i I get “[OK] All ready! You have already set up Grav’s Scheduler in your crontab.” It also appears in the cron logs that the grav cron job is executing without issue. Can anyone point me towards any other things to check? Thank you!

Host:
Centos7.6.1810, php 7.2.13, nginx

#2

Hi @hydrox467 I don’t know the answer to your question but posting an issue on the Admin Panel repo (https://github.com/getgrav/grav-plugin-admin) or asking in the Discord room (https://getgrav.org/discord) might be a better bet for this beta-related issue.

#3

@paulhibbitts Thank you, I’ll check out those other options! Appreciate the help!

#4

Solved!

Turns out to be a literal “user error”. :sunglasses:

This error will show if the scheduler is not installed in the crontab of the php user. I had installed the scheduler in the crontab of a different user. Once I corrected this issue, “Cron not Available” went away.

Thanks!

1 Like
#5

Who is php user? www-data doesn’t work

I manually add this in my /etc/chrontab on Debian

Grave Chrontab

*  * * * * www-data cd /mnt/storage/www/domain-name/html/grav; /usr/bin/php bin/grav scheduler 1>> /dev/null 2>&1

The parameter 1 is right?
If I manually do that command I have this error

Too many arguments, expected arguments "command".
scheduler [-i|--install] [-j|--jobs] [-d|--details]
#6

www-data works. It was my mistake.