Errors starting helium skeleton

I’ve installed and run grav with other themes with no apparent problem. I’ve then installed the Helium skeleton and I’m getting errors when trying to display the site, or when I try to recompile css from the grav admin / gantry page.
The error when trying to access the site is

“An exception has been thrown during the rendering of a template (“Trying to access array offset on value of type null”).”

on this page:


line 14:

{% do gantry.platform.finalize %}

This is on archlinux. The g5-helium directory is in owner [me] and group http throughout.
Any suggestions? Thanks!

@nfortier, Same error has been mentioned in earlier posts. Seems to be related to PHP 7.4. Downgrading to PHP 7.3 solved their issue.

See Breakage on PHP 7.4? (E_NOTICE - Trying to access array offset on value of type null)

Yes indeed. I installed the php73 package from the arch AUR and it’s working.
Thank you!

@nfortier, A bit more research on github tells me it should be fixed in Grav 1.6.23

  • Which Grav version are you using?
  • If not the latest 1.6.23, would you mind testing Grav 1.6.23 on PHP 7.4?

This is grav v1.6.23 (admin v1.9.13), I downloaded the helium skeleton yesteday. I confirm that the errors happen with php (7.4.5-1 in Arch) but not with php73 (7.3.17). I’m using php-fpm, and instead of a web server (for now) I’m using

$ php -S localhost:8000 system/router.php

When running error free that would be php73-fpm and php73 -S…

@nfortier, To rule out the role of the theme, does theme quark also fail on your configuration?

I don’t get errors with the grav-admin package (1.6.23) with Quark, or with the Gateway skeleton, so this seems to point to gantry. I’m running v5.4.32 / g5_helium.

@nfortier, It appears an issue about this error is already created on the Helium repo… It’s still open.

Thank you very much. I’ll keep an eye open for gantry updates.