Error Page on my Navigation Bar

On my navigation bar which is visible from all pages are the following links:

  • Blog
  • About Me
  • Contact
  • Error Page

Those first three I want to keep. The fourth “Error Page” is one I want to go away. How do I make that link go away? Thanks!

I should mention that I don’t have an “Error Page” in my listing of pages and this is a fresh install with a simple Blog theme.

In page editing mode, the “Advanced” tab has a “Visible” attribute which usualy defaults to “Enabled”. Set it to “Disabled” to hide the page. Of course, this assumes your navigation builder has code to ignore any pages which are not visible.

{% for p in page.children.visible %}

The page can still be accessed, as long as it is also published, but it is hidden from menus, sitemaps, etc.

Thanks for the reply, but I don’t think this works for my situation. I don’t have an “Error Page” and this is a clean install. Where might I access the navigation builder code?

Did you have a fourth page? If yes, can you check its YAML header? Most likely there is an error, that’s why you see the error page instead of this one.

At the top level, there are only three pages: blog, about, and contact. I did create an initial blog post page under the blog folder and there’s the default “thankyou” page under contact. Those are all 5 pages. Thank you for your suggestions.

99% sure it’s defined in site.yaml as an additional page to showcase how the error page looks like, in the skeleton

A ‘find . | xargs grep “Error Page” 2> /dev/null’ yields a few cached pages and sites.yaml. Is it okay to edit that file?

Disable cache, in this case.

Or simply clear it

Its in the site.yaml ,found at(user/config/site.yaml) just confirmed it… You have to delete the lines highlighted in the image Aaaa