Email Form is not working properly


#1

I’m using Grav with an Email Form, using both plugins. Unfortunately, the form is not working correctly. The “Thank you” message is not shown at all when you click the submit button. When you click it twice sometimes the message “this form was already sent” pops up, sometimes nothing happens. Also the mail is only sent in 20% of the cases.

here is the page: https://julianschiemann.de#contact

I tried different mail services, different configurations and spend more than an hour looking for a solution. None of the tips I found worked, so I hope to find help here.

Thanks in advance.


#2

I know it’s annoying to type up lots of details clearly, but I don’t see how anyone will be able to help you without much more specific information about what you’ve tried. There are lots of components and variables to a mailing form.

I find mailtrap very useful for testing if your problem is not the mail server, and mail-tester if you are having trouble on the delivery side (esp. GMail). On the sending side, you’ll need to check logs of the service you are using (whether self-hosted or cloud).

Hope that helps. Pleases provide more details to maximise your chance of getting help. Also please share any solutions, as they may be useful to others in future.


#3

Thanks for your message and understanding.

I tried mailtrap and mail-tester already, and iterated through basically all possibilities how to setup the mail and the form plugin. Its not that much you can do (doable in a day of trying).
As before I dont receive mails. Not at all now anymore.

I think the problem is far before the mail server. It seems to be the form or a combination of the form and the mail plugin.

The most prominent behaviour is that the thank you message is not even popping up und the submit button is practically not working. You can see & try it out yourself.

Kind of frustrated after spending a day on that. It doesnt make sense to me.

I can push the submit button 20 times and nothing happens, after a while the message “This form has already been submitted.” pops up. But no email is send.

The browser responds with: Failed to load resource: the server responded with a status of 500 ()
But the filename should be correct.


#4

So probably remove the form’s process.email directives out of the form for testing purposes if you think that is not the issue. You might also try removing the process.save directive to see what effect that has.

With the process.redirect directive (I assume you have), does the path resolve to an existing page that you can access through your browser? (e.g. “/thanks”)

I use the complete URL paths e.g. “/forms/contact/thanks”. I think I had trouble with relative ones (??).

Does that form thanks page have a Twig template? In my case I have “thanks/formdata.md” and a corresponding formdata.html.twig in my theme.

After typing this, I realise you might simply be using the process.message directive instead of a redirect. Haven’t tried that for a long time.

Hope that helps you narrow it down.