Custom CSS not rendering for GRAV site deployed through Heroku

I am not really a coder. Just followed all the instructions and set up a grav site
and deployed it inside a heroku app, using git deployment method.
The site is here

For some reason the custom css is not rendering.
It renders when I run the app from heroku using the open app button.
But when I access the site via browser the css breaks.

Not sure where I am screwing up.
Help please…

@shreyas, The file ‘/user/themes/quark/css/custom.css’ is being loaded, but is empty…

Thank you for taking a look at this.

Really appreciate it.

So here is the css that should show.

That is also the git repo that’s hooked up to my heroku app.


@shreyas, I have no experience with Heroku and only had a look at the Heroku docs at Grav’s documentation.

If you followed the examples given to the letter and use the given post install commands:

"scripts": {
  "compile": [
    "bin/grav install",
    "bin/gpm install quark -y"

Then, if I understand correctly, a fresh copy of Grav and Quark are installed at every deployment at Heroku.

Since you have made changes to Quark itself and not an inherited theme, your custom.css is overridden with an empty file.


  • See what happens if you remove “bin/gpm install quark -y” from above scripts.

If that doesn’t work, I have no other suggestion at the moment…

Thanks @pamtbaau,
Acutally I did follow the tutorial but the app wouldn’t deploy.
This is most probably because I am not sure which json file to place the script.
Is the json file to be placed in the json found in the grav-admin folder or outside in the heroku app folder? I tried them both, to epic failure…