`blueprints()` function: infinite loop

in a custom plugin in Grav 1.6 I had this code:

$grav_user = $this->grav['accounts']->load('my_user');

$grav_user['login'] = 'my_user';
$grav_user['fullname'] = 'John Smith';

$data['access']['site']['login'] = true;


Now, in Grav 1.7, the call to the merge function causes a infinite loop: the problem is in function Grav\Common\User\DataUser\User->blueprints()…but I don’t know why.

@samuele, Have you tried to use:


According the code for UserData::merge():

@deprecated 1.6 Use ->update($data) instead (same but with data validation & filtering, file upload support).

and UserData::update():

// Note: $this->merge() would cause infinite loop as it calls this method.

Hi @pamtbaau, sorry, I had already tried using update instead of merge, but nothing changes: the browser stays frozen and then goes into timeout.

@samuele, In that case I would open an issue at Github.

@pamtbaau, you are right. I have opened this issue. Thank you for your time.

After rebuilding my project with a fresh Grav install, the problem has not recurred.
I close the issue on GitHub.