Acces denied in OpenSUSE web server

Hello,

I am trying to setup a GRAV site in a server running OpenSUSE 15.1 (Leap). As this server is running PHP v7.2.5, I am using GRAV v.1.6.31.

My procedure:

  • unpack GRAV at the webserver folder /srv/www/htdocs,

  • changed the folder name to site.

  • went to the installation folder and run:

    chown -R wwwrun .
    find . -type f | xargs chmod 664
    find ./bin -type f | xargs chmod 775
    find . -type d | xargs chmod 775
    find . -type d | xargs chmod +s
    umask 0002

Here wwwrun is the user under apache is running.

Now, when I point the browser to the folder (https://weberserver/site), I got the message:

# Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the [webmaster](mailto:webmaster@unifal-mg.edu.br).

## Error 403

I tested putting an index.html inside the installation folder, renamed the .htaccess, an got access to it.

I appreciate any help you can give me.

Regards,

Camps

Is there any solution to this issue?

Thx.

I’m also Brazilian, you were not very clear about your question, and I’m pretty sure it’s an apache permission problem.
Is the php extension present in the apache configuration file?
Configured index in apache config file?

I’m not a big user of Apache… but I tested it by renaming the .htaccess file (which is inside the GRAV folder) and put a file in PHP (to have the PHP information installed) and it worked ok. With that, I suppose the Apache php extension is working ok.

About the index, I run grep -ri 'DirectoryIndex' /etc/apache2/* and got:

/etc/apache2/conf.d/gitweb.conf:    DirectoryIndex gitweb.cgi
/etc/apache2/conf.d/mod_php7.conf:        DirectoryIndex index.php4
/etc/apache2/conf.d/mod_php7.conf:        DirectoryIndex index.php5
/etc/apache2/conf.d/mod_php7.conf:        DirectoryIndex index.php7
/etc/apache2/conf.d/mod_php7.conf:        DirectoryIndex index.php
/etc/apache2/httpd.conf:DirectoryIndex index.php index.html index.html.var
/etc/apache2/httpd.conf.rpmnew:DirectoryIndex index.html index.html.var