The number zero in headers

I’m having an issue with the number zero in headers. I have a list of items who need to have 3 digits associated with them. They range from 001 to over 100. Every number starting with a zero is giving me problems. Every time i try adding 001 to the header, it gets automatically reduced to 1.

Basically, this is what I’m doing:
num: 001
name: itemname

But its getting converted to
num: 1
name: itemname

I’ve tried both the editor in expert mode and editing the .md file with a text editor. When editing the .md file directly, It will show up in the editor as “001” but in practice, its still converted to 1. When you go to save the file, it will show the “1” in the editor again as well.

I’ve gone through the documents and haven’t come across anything related to it. Is there something I am doing wrong?

This is just a matter of how YAML works. If you add a numeric value without quotes, it will assume you are adding an integer so it converts 001 to 1.

You probably need to just wrap it in quotes so that it’s treated like a string: "001"

The quotes worked. Thanks alot.