Local installation challenge on Win10 + IIS - solved

I’ve got a working site on Bluehost - no problems but I tried to do a local installation on a Windows 10 machine running IIS and I ran into a brick wall.
Steps I took to solve the problem:

  • Too many to list - but I think I ran in circles at stages
  • The basics were installed IIS with PHP5.6.22
  • Unzipped the core + admin into my wwwroot folder - pointed the browser, but no success (my head is spinning so I cannor remember all the error messages anymore)
  • I placed a phpinfo.php file in the root and executed it just to ensure that php was running - no problem there
  • Trying to run index.php gave no joy. It would seem that the file was not there for all that the browser cared
  • I then played around setting with permissions with iCalcs - I tried various things, I’m not sure exactly any more, but the php error log file showed something about not having permission to create folders - so I sorted that out
  • Eventually I ended up with some obnoxious error, where the brower would change to localhost/admin (after entering “localhost”) and report that the folder did not exist, w hich was verified by my own inspection. But it is not supposed to exist - checked my other working installation on Bluehost.
  • I studied the php.ini file all 2000 lines of it to see where the problem lay. It must have something to do with paths, redirecting URLs. I saw something about the web.config for IIS but I wasn’t sure how to use it.
  • After many hours (trying different settings with php.ini) I decided to do some research as to how the web.config file should be used and where its location should be.
  • Copied it into the root of my local site and EUREKA!!!

Ok, not 100%. I can create and save a page from the Admin module but when I try to access plugins (in the admin module) I get the following error message:
Twig_Error_Runtime
An exception has been thrown during the rendering of a template (“GPM not reachable. Please check your internet connection or check the Grav site is reachable”) in “partials/plugins-list.html.twig” at line 19

Now I cannot initialize a new session. I get a message:
Whoops \ Exception \ ErrorException (E_WARNING)
Cookie names cannot contain any of the following '=,; \r
\013\014’
Where is the malady of my system?

Gave up on this - I’m going to try XAMPP

XAMPP was a much smoother experience - was up and running in about an hour. However, the above two errors reappeared. The first r.e. GPM has to do about me being behind an authenticated proxy - not to serious, I just install stuff manually. The second had to do with a space in the session name (originally ‘grav-site’ which I renamed to ‘something else’. This was identified as a bug and fixed.

Nevertheless, I don’t look back from XAMPP