Inheritance of getgrav-logo svg in Quark theme?


#1

Hi,

How come the Grav logo is not replaced by my logo, if I create an /image/ folder inside /mytheme/ folder, just like in the Quark theme?

All other files seem to be inherited correctly, but the logo stays the same. I’ve gone through other posts here, but couldn’t fully understand what’s the right solution to this.

Thanks for pointing me to the right direction.


#2

A few things I could think of:

  • Have you changed the theme in ‘system.yaml’ from ‘quark’ to ‘mytheme’?
  • Have you copied the file ‘/user/themes/quark/templates/partials/base.html.twig’ to ‘/user/themes/mytheme/templates/partials’ and changed the name of the logo file?
    <section class="navbar-section logo">
       <a href="{{ home_url }}" class="navbar-brand mr-10">{% include('@images/mytheme-logo.svg') %}</a>
    </section>
    

#3

I did not, indeed, copy the file /user/themes/quark/templates/partials/base.html.twig to /user/themes/mytheme/templates/partials and changed the name of the logo file.

I thought it was enough to have another file with the same name in the /mytheme/images folder.

Once copied that twig file and renamed the svg file, it works.

Thanks a lot!


#4

You gave me a little bit more info in your reply:

You are right… Inheritance should first look in your folders and if not found it should look in Quark’s.

The proof is in the pudding… I did the following:

  • Clean blog-skeleton which uses Quark
  • Created new inherited theme using $ bin/plugin devtools newtheme
  • Changed ‘theme’ to ‘mytheme’ in ‘system.yaml’
  • Copied /user/themes/quark/images/grav-logo.svg into /user/themes/mytheme/images/
  • Opened the copied logo and changed it to:
    <svg theme="mytheme" xmlns="http://www.w3.org/2000/svg ..."
    
  • Refreshed the browser
  • Opened devtools to look at the element
  • Guess what… The logo contains ‘theme=“mytheme”’…
  • Renamed the /user/themes/mytheme/images folder in ‘mytheme’ and Quark’s logo is shown again.

Quod erat demonstrandum… your thought was right.

Although your changes have solved the issue, I wonder if the changes solved the real underlying problem…

So I add an extra bonus question:

  • Are you sure you used the exact same name for the logo?

#5

I’m quite sure I used the exact same name for the logo. However, I’m using Quark-Open-Publishing, so we have another ingredient thrown to the mix, Quark-Open-Publishing theme, which is based on Quark…


#6

Nice extra touch… Inheritance of image is now broken indeed.


#7

Not sure what you mean… Where is it broken?


#8

I have no clue where it is broken, but your primary post is reproduce-able when I add ‘quark-open-publishing’ to the mix.

Nevertheless, you have solution at hand…


#9

@marcocevoli
@pamtbaau

I’m brand new to GRAV, but I’m finding it very much to my liking. I too opted for the Quark Open Publishing theme and installed the skeleton on my linux server. I needed to change the icon over to something that my site could use and I wanted to ditch the link to the repository on the top menu bar as I’m using git to backup my pages for personal reasons rather than for open publishing (which I think is a pretty cool idea).

I have a user named grav and the grav install is parked under that user account. I first moved files over from the Quark Open Publishing install over to mytheme:

cd home/grav/www/html/user/themes/quark-open-publishing/templates
cp -r * /home/grav/www/html/user/themes/mytheme/templates

Then I went to edit the twig file with the link to the svg.

nano /home/grav/www/html/user/themes/mytheme/templates/partials/base.html.twig

In nano I just pressed control-w to search for the svg string to find the icon link and change it. BTW Affinity Designer made me look like I knew what I was doing in taking the GRAV logo and modifying it for my use. :sunglasses:

To get rid of the Git repo icon and link on the menubar, I modified the git_sync_repo_link.html.twig file:

nano /home/grav/www/html/user/themes/mytheme/templates/partials git_sync_repo_link.html.twig

I just wrapped the entire contents of the file with twig comment markers:

{# and #}

I’m not used to the discourse forum, but I hope that this post is helpful to somebody and that I got the formatting right. :wrench::nut_and_bolt:


#10

Hi @gnarly.rocks, thanks for sharing your experiences with Quark Open Publishing!

Just today an update to the Quark theme supporting a custom logo choice (via Theme settings) was released (YAY!) and I’ve also now released an updated to QOP to support that option.

BTW, there is also a “Git Sync” location option in QOP theme settings which would also hide the Git Sync link for you - other options there might be of interest too.

Thanks again for sharing your experiences!
Paul


#11

Hi Paul,
Thanks for the tip on the theme settings. I’ll take a look at those more closely. I think I naturally drift towards doing things the hard way or something… :thinking:

I do appreciate your help and guidance a bunch!

Take care,
Michael


#12

LOL. I just went to Themes in the admin panel and there are three listed, mytheme, quark, and quark open publishing. I had not noticed the hyperlink in the theme icons until @paulhibbitts made mention of theme settings. :stuck_out_tongue_winking_eye:

I’d rather have three ssh terminals open with cats walking across my keyboard, apparently.