I think I broke my upgrade

#1

I was performing the upgrade to 1.6.3 from 1.5.10 (I think) on my Dreamhost space. In order to do so I also needed to set it to use PHP 7.2, but in the process I think I managed to break the upgrade. Now the site is down, and I can’t even upgrade from the shell as it throws errors with the AbstractLogger?

[myserver]$ bin/gpm self-upgrade -f
PHP Warning:  include(/home/foo/bar.org/vendor/composer/../psr/log/Psr/Log/AbstractLogger.php): failed to open stream: No such file or directory in /home/foo/bar.org/vendor/composer/ClassLoader.php on line 444
PHP Warning:  include(): Failed opening '/home/foo/bar.org/vendor/composer/../psr/log/Psr/Log/AbstractLogger.php' for inclusion (include_path='.:') in /home/foo/bar.org/vendor/composer/ClassLoader.php on line 444
PHP Fatal error:  Class 'Psr\Log\AbstractLogger' not found in /home/foo/bar.org/vendor/maximebf/debugbar/src/DebugBar/DataCollector/MessagesCollector.php on line 20

Similar errors show in my server logs for accessing the main page.

Any help gratefully received :’(

#2

In the end I gave up and overwrote everything with a fresh download. Once I’d grabbed a couple of the relevant config yaml files, everything seems to be back up and running.

#3

Although… getting the 500 error red box on the dashboard and upon saving pages (and possibly elsewhere) which shows in the logs as:

Premature end of script headers: php72.cgi

Seems to be a relatively generic error, but without a generic fix. Anyone else seeing this?