FTP Installation of Skeleton (Twenty) - Confused

Hi, I’m using an older FTP program called FireFTP, and trying to install one of the skeletons (Twenty) into the webroot of my just created site on our host. I downloaded the zip file. The instructions for the direct upload of the grav installation file don’t seem to work for the skeleton installation files. With my FireFTP FTP client, I can upload the zip file, or I can upload the extracted Twenty download folder (with the site files in it), or I can upload all the contents of the Twenty installation folder. I know about the hidden files as well. When I upload the zip file, my FireFTP program cannot extract it (no option to do that in FireFTP).

If I want to directly upload the files contained within the Twenty installation folder, do I need to upload the whole folder so there is a Twenty… folder in the webroot, or should I be directly installing the individual files from that Twenty folder to the webroot directly?

When I upload them directly, the site loads, but requires the www. prefix to the URL to display. Otherwise, I see a message page from the Host, saying they don’t recognize the domain. I believe I probably have to rename the htaccess.txt file and probably add the code to force it to display with the www prefix, but it won’t work currently without the www. prefix on the URL.

I can’t follow the instructions option #2 that requires a terminal or console. I’ve never done that before. What console/terminal should I be using? Do I need a different FTP client with more features for that console/terminal?

Am I doing this all wrong, or just don’t understand installation? Please help - in as non-technical terms as possible. Thanks

Hello gsande,
In few sentences.
Download twenty skeleton.
Unzip it on your computer.
Upload it to your webserver.
That’s it.

If you unzipped whole content into “twenty” folder, then you should be able reach it using:

“www” or non-www issue is usually DNS issue and should be solved with your hosting provider.

and btw, there’s no installation. Skeleton is basically a whole website, ready to run. You just have to upload it to your server.

Hi Karol,
Thanks for you instructions. Unfortunately, I did exactly as you suggested (also using “Twenty” as the folder name. I extracted the folder from the zip file on my computer (a Win 7 64-bit laptop by the way), then shortened the folder name to just “Twenty”, then uploaded that folder (and its contents) into the public_html root. From there, you said it should load if I entered the URL www.your-host.com/twenty. Unfortunately, it generated an error, which is:

An exception has been thrown during the compilation of a template (“include(/home/USERNAME/public_html/twenty/vendor/twig/twig/lib/Twig/ Compiler.php): failed to open stream: No such file or directory”) in “modular.html.twig”.

(USERNAME obviously being my user name).

I’ll re-read the instructions in the Learn section, but at this point don’t know how to fix this. I don’t use Linux/Unix consoles, but did just download that GIT Windows Terminal if that’s needed.
I’d appreciate any suggestions you may have.

You can try manually cleaning the cache. Go to twig/cache/ and delete all folders and files inside. Also please provide some details about your server, does it meet all requirements specified here: http://learn.getgrav.org/basics/requirements

Hi Karol,
I got it working. If you extract the grav-skeleton-twenty-site-v1.0.0.zip file, you will see one folder. I would have expected that folder to contain the files for the site, and uploaded that, then added that folder name to the end of my domain name, and thats what generated the error. I looked at that extracted folder, and inside it was another folder, and inside that folder were all the site files. So, the site files were nested down two levels in that zip, rather than one. Take a look. I would have thought the site files would be contained in that first extracted folder.
When I saw that, on the server, I moved that entire second level folder (the one containing the site files), and placed that directly in the public_html root. I had already renamed the htaccess file to .htaccess. I’m running on an Apache server, which is running 5.4 up to 5.6 PHP. I set it at 5.4 for this site. Once I moved the subfolder with the files into the root, I renamed the folder to “twenty” (its shorter), and then the URL www.your-host.com/twenty worked fine and loaded the site with out error. I still have a LOT to learn on this, but slowly making progress. Sorry to ask for your help, but I really do appreciate it. I think I’m good for now, and am continuing to study the documentation. I really think that “double-nested” grav-skeleton-twenty-site-v1.0.0.zip file is an error with one extra level of folders in it - unless I’m missing something.
Thanks again.

I think it really depends on ZIP client. For example on MacOSX core unarchiver extracts everything into one folder but for example few windows unarchivers creates additional directories. Anyways, I’m glad you got it working :slight_smile:

I’m beginning to think I should be doing this on my Mac rather than my Win 7 machine. Thanks again.

Follow-up but related question. My web host tells me that I have to have the site files located in the webroot, including the .htaccess file in order to use the URL www.your-hostname.com, rather than www. your-hostname.com/twenty that it is currently.
Can I move the entire contents of my “twenty” folder into the root, and eliminate the folder - so the site loads with just www.your-hostname.com?

sure, just make sure you move ALL the files including the hidden ones in twenty/ folder such as .htaccess

Thanks. It seemed like it should work fine, and that’s what I’d prefer to do anyway. I’ll move everything. Thanks rhukster!

fyi - I voted for Grav