Caching Issue with blog listing

I am having a challenge with a portion of my site and the caching configuration. The site is cached, but I am having challenges disabling the cache when I list pages while in a blog format. I put in the following entry blog page, but it’s still caching:

	enabled: false
never_cache_twig: true

cache_control: false

Hi @crusnac, perhaps try this on your blog parent page?
cache_enable: false

Do you know if there is an option to exclude caching for anytime I pass a URL ?=parameter? This would achieve my need.

There might be, but I am not aware of it. Perhaps a small custom plugin could do this?

Might this post be helpful? Performance: Completely disable twig caching vs. disbling cache on modulars

Anyone else here have thoughts on this one?

I tried this Performance: Completely disable twig caching vs. disbling cache on modulars, but no luck.

I wonder if there is some twig code, that I can disable caching if a parameter is passed?

What exactly are you trying to do via a Twig clear cache? Do you get what you are looking for with the cache turned off in the system.yaml file?

I figured out my issue. I was including a template in my content {% include 'partials/subpages.html.twig' %} which was being cached as part of the content. I added some logic to the main page template to include a template based on a front-matter setting. This is now following the caching logic that I was expecting.

That’s great @crusnac, glad you got it working.